Version Restore

Hi,

I tried to restore one of my workbooks to an earlier version yesterday and ever since, whenever I try and open that workbook, I get an error saying that there are no worksheets in this workbook.

Is there some sort of a time-frame that it takes for a restore to happen or has my work been corrupted / lost?

Greatly appreciate any help on this.

Thank you.

Welcome to the community Faizan. It is possible that there was a problem with your restore at our end. We will investigate and get back to you soon. Sorry about that.
Generally, restoring a workbook takes you to the final restored state when the restore is complete. This should not be a very long activity.

Request you to check the workbook now. We have attempted to restore the same snapshot that you tried, verifying that it indeed has data in the worksheets. But we don’t have access to your workbook so can not confirm.
Note that this is a one off failure and we are working constantly towards making the system resilient in this regard. We would be happy to help if you still have any issues.

1 Like

@santosh I can confirm that the workbook is restored and I can see my data in it again. I understand the beta nature of spreadsheet.com and issues can come up. Thank you for resolving this so quickly!

2 Likes