Using keyboard with Select type

Created a Gender column with Select type, two options, Female and Male. When I fill in a row, I’m typing along. I tab to that cell and hit the “M” key. The selections pop up, Female is listed first and is highlighted. Hitting M does not highlight Male. Hit return and Female is selected.

Expected behavior is like filling in online forms. When I go to a State field, I hit “I” to get to Idaho. Sometimes I have to hit “I” more than once to cycle through Idaho, Illinois, Indiana, Iowa.

When needing to fill in lots of data, keyboard entry is very necessary to avoid having to mouse around so much.

1 Like

Fully agree. We’ll prioritise this one. I’ll keep you posted.

1 Like

Tracking this as issue # 001538

Hello wanted to share an update.

  1. “… Hit return and Female is selected.” -> We are fixing this one. Expect it to appear in production in a matter of days.

  2. “When I go to a State field, I hit “I” to get to Idaho. Sometimes I have to hit “I” more than once to cycle through Idaho, Illinois, Indiana, Iowa.”

This one is a little different. The Select is dissimilar to a typical form select box in the sense that the input can often accept data that is not one of the Select options. For example “iiiii”. So your second i will type ii into the box and filter out all I-states. However one could still navigate from Idaho to Illinois using down arrow key. It is the same amount of keystrokes. GSheets has a similar behaviour.

Sounds good. I have seen other cases where you have to type in “Id” to get to “Idaho”. I tried it and it works.

However. Once I get to the desired selection, I can’t simply tab to move on. I have to hit return. Hitting “i” will bring up Idaho, Illinois, Indiana, and Iowa, and Idaho will be highlighted. I then hit tab to move on to the next field expecting Idaho to be put in place. But it doesn’t, “i” is left in place. If I hit return instead of tab, then Idaho gets selected, but then the cursor move down to the next row and I have to move up and over to get to the next cell on the row I was on.

I can see that since “i” is valid when the column is not marked Strict, then when hitting tab it will not be known if the user intended “i” or “Idaho.” In Excel, (assuming all four “I” states exist in that column) “i” does not show anything, but “id” will bring up “Idaho.” Hitting tab will leave “Idaho” in the cell, not “id”. If I wanted just “id” in the cell in Excel, what I have to do is “id”, then backspace, then tab to move to the next cell. This behavior is the same in Sheets.

In SS, hitting “i” brings up all four states and highlights the first one. I like that. Because in Excel, I don’t know if I’m spelling it right until there is only one choice left, then it will show it. So yours is an added benefit by showing all possible choices.

What I recommend is the following. Start typing “i”. All four states show up and Idaho is highlighted. If I want Idaho, hit tab, Idaho will be filled in and I’m in the next cell. If I wanted one of the other three states, I could either type “l”, “o”, or “n” to select one of the others, then hit tab, or I could use the arrow keys to move to the desired one and hit tab. The resulting highlighted entry is then in the cell and I’m on to the next tab.

If I wanted “ida” instead of “Idaho”, then I would type in “ida”, backspace to ignore the “Idaho” suggestion, then tab, and “ida” would be left in the cell. This is the procedure in Excel and Sheets.

In SS, if I type in “Idaho” then tab I get the colored item from the list. But if I type in “idaho” (lower-case) then it leaves “idaho” uncolored. In Excel, it is case-insensitive and would have left “Idaho” in the cell. So I would prefer that in SS that it be case insensitive when looking for an existing entry in the select list.

If the column’s Strict box is checked, typing in keys ignored. All the select items pop up but nothing is entered into the cell. It forces moving hands from the keyboard to the arrow keys or mouse to enter that field. It slows down data entry. Not good. Behave the same as what I’ve described above, but with the additional restrictions of ignoring invalid keystrokes. For example, “i” brings up the four states. “ix” the x is ignored and the four states are still shown. That will indicate to me that “ix” is an invalid entry and not allowed. Typing in “ida”, then backspace, the backspace will be ignored and “Idaho” will still be shown and highlighted. Pressing tab in either of those cases will move to the next cell with “Idaho” entered.

Thanks for the input. Allow us to process this and get back.

Issue #001538 is now fixed in production as of the June 6th release.

With regards to the original issue filed here, the fix addresses this: “Created a Gender column with Select type, two options, Female and Male. When I fill in a row, I’m typing along. I tab to that cell and hit the “M” key. The selections pop up, Female is listed first and is highlighted. Hitting M does not highlight Male. Hit return and Female is selected.”