How to Set Table Header Row

According to the documentation, I set a table row by selecting the row and right clicking. This looks about right on their sample worksheets.

However, my new worksheet does not bring up that option when I right click on the row! Is there something I need to do to make that option available, and if so what is it (and please update the docs!).


Hi Heidi,

Thank you for reaching out and I’m happy to help with getting the Table Header Row setup for you.

When selecting the row and then right-clicking you should be seeing the option to “Set as Table Header Row”. If you are not seeing this option could I’d be happy to schedule time for a quick call because this would seem like you are running into a Bug.

I’m sharing a screenshot of the options you should be seeing when right-clicking into the row once it’s been selected.


1 Like

Hi there! Maybe you could share a screenshot of the options that you see when you right click on the row? (Fellow customer here)

1 Like


Thomas, See image above. I was thinking I needed to set an option to allow header zone first. Happy to hop on a call either right now or 2:00 today.

Hi Heidi,

Thank you for sending this over. I just sent you an email with the invite link for a Zoom meeting room so let me know if you don’t receive that in the next few minutes.

Thomas Van Steyn

Thank you for reporting this @Heidi_Brumbaugh and thanks for jumping in here @thomas !

There is a known issue whereby in some cases the cell/range context menu appears instead of the row context menu when right-clicking a row header. We’re tracking this as issue #s 001858 and 002176.

The best way to avoid this for now is to first left click the row header to select it and then right click on the row header. Sorry for the hassle, we’ll be prioritizing a fix for this.

Thank you for taking the time to hop on a Zoom call Heidi.

Solution (For other users who may run into this)

Table Header Row cannot be set when there are (Filters, Sorts, or Hidden Columns) applied to a Worksheet. This is something we will be updating in the future where we warn users when one of these is applied and you attempt to add a Table Header Row.


Thanks, Thomas, and nice meeting you! If I might suggest, you could include the option in the menu but greyed out, and if the user hovers over the option a tool-tip might explain the issue.

1 Like

Aw, thanks Thomas. Good to know.

1 Like

I cannot get right-click to work as expected. I tried left-click followed by right-click. No joy. This is what I see no matter what I try:

Safari Version 15.0 (16612., 16612)
macOS 11.5 (20G71)

Hi Hans,

Sorry to hear that you are running into this. I’ve tried to replicate this on my end in Safari and I was not able to replicate this issue.

If you are open to it would you mind hopping on a quick call where we can walk through what you are seeing and hopefully get this working for you? If that works I’ll send you an email with a calendar invitation for a Zoom call.

1 Like

Sure. Available now for a while.

@Thomas_Van_Steyn has confirmed (via a Zoom) that this might be an issue with Safari 15.